June 6, 2016 at 5:18AM

1

Resolve 12 rendering progressive as interlaced

Okay, so this is super-specific, but I'm praying someone on here can figure this out.

I've started editing in Resolve 12, using footage shot as follows: 1080p MOV H.264, 25fps progressive. When I add this to Resolve the default project (which is 24fps) offers to change the project settings to match the media - so I select that.

Now when it comes to rendering I want to keep it as MOV H.264. So I choose those settings, render... and it comes out as *interlaced* 25fps.

So I start the whole process again, exactly as above - but now use 24fps footage (everything else the same). Export as above, only at 24fps. And bingo, the footage is 24fps progressive.

I'm happy to acknowledge that I'm not an expert, maybe I'm misunderstanding something, maybe it doesn't matter that the 25fps version is interlaced - it looks fine on playback. But I've always been of the mind that you want to change as little as possible in terms of format, and more to the point it's just bugging me that it seems to be doing this automatically with no obvious way of stopping it.

Any thoughts/advice greatly appreciated.

Jon.

5 Comments

Why not create a project at 25p which matches the original footage?

Conforming a 25p file to a 24p file will slightly slow down the video (unless it uses blending but you really want to stay away from that). The slowing down is usually not a problem except for the sound, you probably want to re-sample the sound while remaining proper pitch.

The interlaced thing is weird, are you 100% sure you are not trying to edit or render standard definition video?

June 6, 2016 at 10:59AM, Edited June 6, 10:59AM

2
Reply
avatar
Cary Knoop
Member
2219

Hi Cary,

Thanks for replying.

I've tried creating a new project with 25p, 1080 settings, and all seems fine - when I import the footage it doesn't throw out the 'mismatched media' warning so I assume it's all good - until I come to render it and the resulting file is interlaced. I have tried exporting in other formats - MPEG-4, AVI - it's still treating the footage as if it's interlaced. I think if anything the problem is Resolve interpreting the footage as interlaced to begin with for some reason.

I'll keep plugging away...

Cheers,

Jon

Jon Mills

June 6, 2016 at 11:45AM

Tiny update:

The best work-around I have so far is to take the files Resolve produces, transcode them back to 1080p 25fps progressive using mpeg Streamclip, then I get a 1080p 25fps progressive file. Worst case scenario is I grade in Resolve, export and then batch process all those files. Just seems a bit redundant...

June 6, 2016 at 12:11PM

0
Reply
avatar
Jon Mills
Filmmaker
623

Be careful with transcoding, you will lose quality, also some programs will blend your frames if you change frame rate and all you get is a big mess.

There is a free program called MediaInfoXP, download that (only the portable version as you do not want any adware), with that program you can check if your source is indeed progressive.

For instance older HD cameras often record full HD interlaced and even 24p material can sometimes be recorded (faux) interlaced.

http://muldersoft.com/#mixp

Also if you upload a few seconds of the footage (assuming that is allowed rights wise) I can take a look at it. However you would need to cut the the original H.264 stream to a few seconds, do not transcode it. A tool like AVIDemux will do that.

June 6, 2016 at 1:10PM, Edited June 6, 1:13PM

1
Reply
avatar
Cary Knoop
Member
2219

Thanks again.

MediaInfoXP is saying both the input and output (i.e. post Resolve) files are progressive, so it looks like Vegas is where the problem is, as that's identifying the rendered footage as interlaced.

June 6, 2016 at 1:46PM

0
Reply
avatar
Jon Mills
Filmmaker
623

Your Comment